Web Connection
Help deploying my first webapp
Gravatar is a globally recognized avatar based on your email address. Help deploying my first webapp
  Chris Jewell
  All
  May 9, 2019 @ 04:24am

Hi,

Please ignore this message, the problem is solved and the solution was pretty obvious really..." rolls eyes "... in case this comes up for anyone else, the issue was permissions on the \temp\ folder, once I allowed full access to the USERS account it worked.

I'm after some advice\help with deploying my app, please.

I'm deploying onto a Windows SBS 2011 Standard server, using WebConnect 7.0 and IIS 6.1. IIS is already installed. I used the 'Build.bat' to zip & copy all the files to the server and then I manually copied over the runtime files and any other dependencies. Then, from the command line (in admin mode) I ran MyProject.exe CONFIG, which worked without errors. The exe loads and I see the WebConnect server form, all good so far, but when I click 'Browse Site' the default page loads but I cannot access any of my processes, it just times out. The process requests do not appear on the WebConnect form.

I've noticed that when a process request is physically sent from the local browser I can see a WC_*.tmp file appears in the \deploy\temp\ directory, so, it appears to be an issue with the exe not seeing the requests as they come in, any suggestions welcome?

If you need any more information let me know?

Thank you, Chris

Gravatar is a globally recognized avatar based on your email address. re: Help deploying my first webapp
  Rick Strahl
  Chris Jewell
  May 9, 2019 @ 01:35pm

Hi Chris,

Glad you figured it out via Permissions.

This suggests you're using a specific account in your IIS Application Pool and you probably should dial the permissions in your temp folder to match that account. IIS is what's writing the files and most likely your FoxPro server also runs under this account.

+++ Rick ---

© 1996-2019