West Wind Client Tools
Unable to load wwDotNetBridge
Gravatar is a globally recognized avatar based on your email address. Unable to load wwDotNetBridge
  Julio Cesar Santone
  All
  Aug 30, 2017 @ 06:35am

Hi,

I´m having trouble with wwDotNetBridge in Windows XP SP3 with .NET 4 Full Framework

When I try to load the library I´m getting this error: Unable to load wwDotNetBridge: Unable to load Clr Instance. 0x80131604:

If I try with Version "V2" then I´m getting this error: Unable to load wwDotNetBridge: Unable to load Clr Instance. 0x8013101b:

I´m using the lastest version of West Wind Client Tools registered a few days ago.

DLL is not Blocked.

The .NET Frameworks installed on the machine are:

No problem with newer OS and .Net framworks.

Regards

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Rick Strahl
  Julio Cesar Santone
  Aug 30, 2017 @ 08:28pm

I don't know what .NET Framework 4 Extended means. I think that should just be full framework. If you have full framework installed you can uninstall the client profile.

.NET 2.0 no longer works with the latest version of wwdotnetbridge because it's compiled to .NET Framework 4.0 and in order to load the assembly V4 is required. I'm looking into perhaps going back to targeting 2.0, but I have to see what the changes were that required the move to 4.0.

+++ Rick ---

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Julio Cesar Santone
  Rick Strahl
  Aug 30, 2017 @ 08:51pm

Hi Rick,

When you download Version 4 Full Framwork (dotNetFx40_Full_setup.exe) Client Profile and Extended are installed. I didn´t find any other version for full framework V4 under Windows XP.

I other hand maybe I'm going to start requiring at least Windows 7 SP1 or higher to run the software. Windows XP it's way too old...

Thank you for your time ! Regards

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Rick Strahl
  Julio Cesar Santone
  Aug 31, 2017 @ 01:22pm

I other hand maybe I'm going to start requiring at least Windows 7 SP1 or higher to run the software. Windows XP it's way too old...

Yeah that's probably a good idea...

Just to be clear though - current versions don't support launching into the .NET 2.0 runtime.

You can however still load .NET 2.0 components no problem - it's just the actual runtime loading requires .NET 4.0 (due to some of the dependencies we've added to the framework as part of the client tools that in turn require .NET 4.0). Also if another application/component has already loaded .NET 2.0 runtime, wwDotnetBridge should also still work on the .NET 2.0 runtime - it's just the actual loading that is not supported.

+++ Rick ---

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Julio Cesar Santone
  Rick Strahl
  Aug 31, 2017 @ 03:10pm

Ok

Thank you very much !

Regards.

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Robert
  Julio Cesar Santone
  Sep 19, 2017 @ 09:11am

Hello Julio and or Rick, I am having the exact same problem outlined by Julio in this original post. i.e. same OS, same .NET versions installed. I get the error : "Unable to load wwDotNetBridge: Unable to load Clr Instance. 0x80131604" Is wwDotNetBridge just not supported on XP? Thanks.

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Rick Strahl
  Robert
  Sep 19, 2017 @ 11:44am

This should work as long as you call .NET 4 (full framework, not the client profile).

I haven't tested on XP since we switched to .NET 4.0 only in the 6.0 release frame, but I see no reason this shouldn't work if the right .NET framework is installed. Also there can be other reasons - blocked dlls, and network permissions. unfortunately the error reporting from the runtime loader doesn't provide much information on why things fail :-(.

+++ Rick ---

Gravatar is a globally recognized avatar based on your email address. re: Unable to load wwDotNetBridge
  Julio Cesar Santone
  Rick Strahl
  Sep 19, 2017 @ 09:29pm

Hi Robert and Rick,

I believe it's related to this issue: https://github.com/RickStrahl/wwDotnetBridge/issues/6 I'm using WWCT V 6.10 (Registered). Maybe for Windows XP will work an old compilation of the library. I'm guessing here but I don´t have an earlier version to test it.

OTOH Windows XP is too old so I'm requesting my clients to update the OS whenever possible

Regards

© 1996-2017